What’s Vulnerable › Vulnerabilities
CVE-2025-23209: Craft CMS Code Injection Vulnerability
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2025-02-20
- EPSS: 21.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-18 · updated 2026-06-17
- Weakness: CWE-94
Description
Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. This is an remote code execution (RCE) vulnerability that affects Craft 4 and 5 installs where your security key has already been compromised. Anyone running an unpatched version of Craft with a compromised security key is affected. This vulnerability has been patched in Craft 5.5.8 and 4.13.8. Users who cannot update to a patched version, should rotate their security keys and ensure their privacy to help migitgate the issue.
Affected products
- craftcms cms: from 4.0.0 (excl.) before 4.13.8; from 5.0.0 (excl.) before 5.5.8; 4.0.0, 4.0.0-rc1, 4.0.0-rc2, 4.0.0-rc3, 5.0.0, 5.0.0-rc1 — fixed in 4.13.8, 5.5.8
How to fix
Upgrade to a fixed version: craftcms cms 4.13.8, 5.5.8. Check the vendor advisory for mitigations.
References
- https://craftcms.com/knowledge-base/securing-craft#keep-your-secrets-secret
- https://github.com/craftcms/cms/commit/e59e22b30c9dd39e5e2c7fe02c147bcbd004e603
- https://github.com/craftcms/cms/security/advisories/GHSA-x684-96hh-833x
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-23209
Get alerted when CVE-2025-23209 or the next vulnerability affects your stack