What’s Vulnerable › Vulnerabilities
CVE-2025-23217: Mitmweb API Authentication Bypass Using Proxy Server
- Severity: high (CVSS 8.2 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-06 · updated 2026-06-17
- Weakness: CWE-288
Description
mitmproxy is a interactive TLS-capable intercepting HTTP proxy for penetration testers and software developers and mitmweb is a web-based interface for mitmproxy. In mitmweb 11.1.1 and below, a malicious client can use mitmweb's proxy server (bound to `*:8080` by default) to access mitmweb's internal API (bound to `127.0.0.1:8081` by default). In other words, while the cannot access the API directly, they can access the API through the proxy. An attacker may be able to escalate this SSRF-style access to remote code execution. The mitmproxy and mitmdump tools are unaffected. Only mitmweb is affected. This vulnerability has been fixed in mitmproxy 11.1.2 and above. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- mitmproxy: before 11.1.2
References
- https://en.wikipedia.org/wiki/Server-side_request_forgery
- https://github.com/mitmproxy/mitmproxy/blob/main/CHANGELOG.md#06-february-2025-mitmproxy-1112
- https://github.com/mitmproxy/mitmproxy/security/advisories/GHSA-wg33-5h85-7q5p
Get alerted when CVE-2025-23217 or the next vulnerability affects your stack