What’s Vulnerable › Vulnerabilities
CVE-2025-2330: All-in-One Addons for Elementor – WidgetKit <= 2.5.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via button+modal Widget
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The All-in-One Addons for Elementor – WidgetKit plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'button+modal' widget in all versions up to, and including, 2.5.4 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- shamsbd71 All-in-One Addons for Elementor – WidgetKit: before 2.5.5 — fixed in 2.5.5
How to fix
Upgrade to a fixed version: shamsbd71 All-in-One Addons for Elementor – WidgetKit 2.5.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/widgetkit-for-elementor/trunk/elements/button-modal/template/view.php#L86
- https://plugins.trac.wordpress.org/changeset/3283765/widgetkit-for-elementor/tags/2.5.5/elements/button-modal/template/view.php
- https://wordpress.org/plugins/widgetkit-for-elementor/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/83d5337b-8c06-41ee-b18c-2c39150a7f30?source=cve
Get alerted when CVE-2025-2330 or the next vulnerability affects your stack