What’s Vulnerable › Vulnerabilities
CVE-2025-23304
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-13 · updated 2026-06-17
- Weakness: CWE-22
Description
NVIDIA NeMo library for all platforms contains a vulnerability in the model loading component, where an attacker could cause code injection by loading .nemo files with maliciously crafted metadata. A successful exploit of this vulnerability may lead to remote code execution and data tampering.
Affected products
- NVIDIA NeMo Framework: before 2.3.2 — fixed in 2.3.2
How to fix
Upgrade to a fixed version: NVIDIA NeMo Framework 2.3.2. Check the vendor advisory for mitigations.
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-23304
- https://nvidia.custhelp.com/app/answers/detail/a_id/5686
- https://www.cve.org/CVERecord?id=CVE-2025-23304
Get alerted when CVE-2025-23304 or the next vulnerability affects your stack