What’s Vulnerable › Vulnerabilities
CVE-2025-23364
- Severity: high (CVSS 8.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-08 · updated 2026-06-17
- Weakness: CWE-347
Description
A vulnerability has been identified in TIA Administrator (All versions < V3.0.6). The affected application improperly validates code signing certificates. This could allow an attacker to bypass the check and exceute arbitrary code during installations.
Affected products
- Siemens TIA Administrator: before 3.0.6 — fixed in 3.0.6
How to fix
Upgrade to a fixed version: Siemens TIA Administrator 3.0.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-23364 or the next vulnerability affects your stack