What’s Vulnerable › Vulnerabilities
CVE-2025-23367: Org.wildfly.core:wildfly-server: wildfly improper rbac permission
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-30 · updated 2026-09-18
- Weakness: CWE-284
Description
A flaw was found in the Wildfly Server Role Based Access Control (RBAC) provider. When authorization to control management operations is secured using the Role Based Access Control provider, a user without the required privileges can suspend or resume the server. A user with a Monitor or Auditor role is supposed to have only read access permissions and should not be able to suspend the server. The vulnerability is caused by the Suspend and Resume handlers not performing authorization checks to validate whether the current user has the required permissions to proceed with the action.
Affected products
- Red Hat JBoss EAP: from 7.4 before 7.4.21; from 8.0.0 before 8.0.7 — fixed in 7.4.21, 8.0.7
- Wildfly: before 27.0.1; 28.0.0-beta1 — fixed in 27.0.1
How to fix
Upgrade to a fixed version: Red Hat JBoss EAP 7.4.21, 8.0.7; Wildfly 27.0.1. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2025:3465
- https://access.redhat.com/errata/RHSA-2025:3467
- https://access.redhat.com/errata/RHSA-2025:3989
- https://access.redhat.com/errata/RHSA-2025:3990
- https://access.redhat.com/errata/RHSA-2025:3992
- https://access.redhat.com/errata/RHSA-2025:4552
- https://access.redhat.com/security/cve/CVE-2025-23367
- https://bugzilla.redhat.com/show_bug.cgi?id=2337620
- https://github.com/advisories/GHSA-qr6x-62gq-4ccp
Get alerted when CVE-2025-23367 or the next vulnerability affects your stack