What’s Vulnerable › Vulnerabilities
CVE-2025-23387: Rancher's SAML-based login via CLI can be denied by unauthenticated users
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-11 · updated 2026-06-17
- Weakness: CWE-200
Description
A Exposure of Sensitive Information to an Unauthorized Actor vulnerability in SUSE rancher allowed unauthenticated users to list all CLI authentication tokens and delete them before the CLI is able to get the token value.This issue affects rancher: from 2.8.0 before 2.8.13, from 2.9.0 before 2.9.7, from 2.10.0 before 2.10.3.
Affected products
- SUSE Rancher: from 2.8.0 before 2.8.13; from 2.9.0 before 2.9.7; from 2.10.0 before 2.10.3 — fixed in 2.10.3, 2.8.13, 2.9.7
How to fix
Upgrade to a fixed version: SUSE Rancher 2.10.3, 2.8.13, 2.9.7. Check the vendor advisory for mitigations.
References
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2025-23387
- https://github.com/rancher/rancher/security/advisories/GHSA-5qmp-9x47-92q8
Get alerted when CVE-2025-23387 or the next vulnerability affects your stack