What’s Vulnerable › Vulnerabilities

CVE-2025-23388: Unauthenticated stack overflow in /v3-public/authproviders API

Description

A Stack-based Buffer Overflow vulnerability in SUSE rancher allows for denial of service.This issue affects rancher: from 2.8.0 before 2.8.13, from 2.9.0 before 2.9.7, from 2.10.0 before 2.10.3.

Affected products

How to fix

Upgrade to a fixed version: SUSE Rancher 2.10.3, 2.8.13, 2.9.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-23388 or the next vulnerability affects your stack