What’s Vulnerable › Vulnerabilities
CVE-2025-23389: Rancher does not Properly Validate Account Bindings in SAML Authentication Enables User Impersonation on First Login
- Severity: high (CVSS 8.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-11 · updated 2026-06-17
- Weakness: CWE-284
Description
A Improper Access Control vulnerability in SUSE rancher allows a local user to impersonate other identities through SAML Authentication on first login. This issue affects rancher: from 2.8.0 before 2.8.13, from 2.9.0 before 2.9.7, from 2.10.0 before 2.10.3.
Affected products
- SUSE Rancher: from 2.8.0 before 2.8.13; from 2.9.0 before 2.9.7; from 2.10.0 before 2.10.3 — fixed in 2.10.3, 2.8.13, 2.9.7
How to fix
Upgrade to a fixed version: SUSE Rancher 2.10.3, 2.8.13, 2.9.7. Check the vendor advisory for mitigations.
References
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2025-23389
- https://github.com/rancher/rancher/security/advisories/GHSA-mq23-vvg7-xfm4
Get alerted when CVE-2025-23389 or the next vulnerability affects your stack