What’s Vulnerable › Vulnerabilities
CVE-2025-23391: Rancher: Restricted Administrator can change Administrator's passwords
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-11 · updated 2026-06-17
- Weakness: CWE-266
Description
A Incorrect Privilege Assignment vulnerability in SUSE rancher allows a Restricted Administrator to change the password of Administrators and take over their accounts. This issue affects rancher: from 2.8.0 before 2.8.14, from 2.9.0 before 2.9.8, from 2.10.0 before 2.10.4.
Affected products
- SUSE Rancher: from 2.8.0 before 2.8.14; from 2.9.0 before 2.9.8; from 2.10.0 before 2.10.4 — fixed in 2.10.4, 2.8.14, 2.9.8
How to fix
Upgrade to a fixed version: SUSE Rancher 2.10.4, 2.8.14, 2.9.8. Check the vendor advisory for mitigations.
References
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2025-23391
- https://github.com/rancher/rancher/security/advisories/GHSA-8p83-cpfg-fj3g
Get alerted when CVE-2025-23391 or the next vulnerability affects your stack