What’s Vulnerable › Vulnerabilities
CVE-2025-23419: TLS Session Resumption Vulnerability
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-05 · updated 2026-06-17
- Weakness: CWE-863
Description
When multiple server blocks are configured to share the same IP address and port, an attacker can use session resumption to bypass client certificate authentication requirements on these servers. This vulnerability arises when TLS Session Tickets https://nginx.org/en/docs/http/ngx_http_ssl_module.html#ssl_session_ticket_key are used and/or the SSL session cache https://nginx.org/en/docs/http/ngx_http_ssl_module.html#ssl_session_cache are used in the default server and the default server is performing client certificate authentication. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- Debian Linux: 11.0
- nginx: from 1.11.4 before 1.26.3; from 1.27.0 before 1.27.4 — fixed in 1.26.3, 1.27.4
- F5 NGINX Plus: from r28 before r32; r32, r32-p1, r33, r33-p1 — fixed in r32
How to fix
Upgrade to a fixed version: nginx 1.26.3, 1.27.4; F5 NGINX Plus r32. Check the vendor advisory for mitigations.
References
- https://my.f5.com/manage/s/article/K000149173
- http://www.openwall.com/lists/oss-security/2025/02/05/8
- https://lists.debian.org/debian-lts-announce/2025/03/msg00017.html
Get alerted when CVE-2025-23419 or the next vulnerability affects your stack