What’s Vulnerable › Vulnerabilities
CVE-2025-24005: Local Privilege Escalation via Vulnerable SSH Script
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-08 · updated 2026-06-17
- Weakness: CWE-20
Description
A local attacker with a local user account can leverage a vulnerable script via SSH to escalate privileges to root due to improper input validation.
Affected products
- Phoenixcontact Charx Sec-3000 Firmware: before 1.7.3 — fixed in 1.7.3
- Phoenixcontact Charx Sec-3050 Firmware: before 1.7.3 — fixed in 1.7.3
- Phoenixcontact Charx Sec-3100 Firmware: before 1.7.3 — fixed in 1.7.3
- Phoenixcontact Charx Sec-3150 Firmware: before 1.7.3 — fixed in 1.7.3
How to fix
Upgrade to a fixed version: Phoenixcontact Charx Sec-3000 Firmware 1.7.3; Phoenixcontact Charx Sec-3050 Firmware 1.7.3; Phoenixcontact Charx Sec-3100 Firmware 1.7.3; Phoenixcontact Charx Sec-3150 Firmware 1.7.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-24005 or the next vulnerability affects your stack