What’s Vulnerable › Vulnerabilities
CVE-2025-24006: Privilege Escalation via Insecure SSH Permissions
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-08 · updated 2026-06-17
- Weakness: CWE-269
Description
A low privileged local attacker can leverage insecure permissions via SSH on the affected devices to escalate privileges to root.
Affected products
- Phoenixcontact Charx Sec-3000 Firmware: before 1.7.3 — fixed in 1.7.3
- Phoenixcontact Charx Sec-3050 Firmware: before 1.7.3 — fixed in 1.7.3
- Phoenixcontact Charx Sec-3100 Firmware: before 1.7.3 — fixed in 1.7.3
- Phoenixcontact Charx Sec-3150 Firmware: before 1.7.3 — fixed in 1.7.3
How to fix
Upgrade to a fixed version: Phoenixcontact Charx Sec-3000 Firmware 1.7.3; Phoenixcontact Charx Sec-3050 Firmware 1.7.3; Phoenixcontact Charx Sec-3100 Firmware 1.7.3; Phoenixcontact Charx Sec-3150 Firmware 1.7.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-24006 or the next vulnerability affects your stack