What’s Vulnerable › Vulnerabilities
CVE-2025-24010: Vite allows any websites to send any requests to the development server and read the response
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-20 · updated 2026-06-17
- Weakness: CWE-346
Description
Vite is a frontend tooling framework for javascript. Vite allowed any websites to send any requests to the development server and read the response due to default CORS settings and lack of validation on the Origin header for WebSocket connections. This vulnerability is fixed in 6.0.9, 5.4.12, and 4.5.6.
Affected products
- vitejs vite: before 4.5.5; from 5.0.0 before 5.4.12; from 6.0.0 before 6.0.9 — fixed in 4.5.5, 5.4.12, 6.0.9
How to fix
Upgrade to a fixed version: vitejs vite 4.5.5, 5.4.12, 6.0.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-24010 or the next vulnerability affects your stack