What’s Vulnerable › Vulnerabilities
CVE-2025-24015: Deno's AES GCM authentication tags are not verified
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-03 · updated 2026-06-17
- Weakness: CWE-347
Description
Deno is a JavaScript, TypeScript, and WebAssembly runtime. Versions 1.46.0 through 2.1.6 have an issue that affects AES-256-GCM and AES-128-GCM in Deno in which the authentication tag is not being validated. This means tampered ciphertexts or incorrect keys might not be detected, which breaks the guarantees expected from AES-GCM. Older versions of Deno correctly threw errors in such cases, as does Node.js. Without authentication tag verification, AES-GCM degrades to essentially CTR mode, removing integrity protection. Authenticated data set with set_aad is also affected, as it is incorporated into the GCM hash (ghash) but this too is not validated, rendering AAD checks ineffective. Version 2.1.7 includes a patch that addresses this issue.
Affected products
- denoland deno: from 1.46.0 before 2.1.7 — fixed in 2.1.7
How to fix
Upgrade to a fixed version: denoland deno 2.1.7. Check the vendor advisory for mitigations.
References
- https://github.com/denoland/deno/commit/0d1beed
- https://github.com/denoland/deno/commit/4f27d7cdc02e3edfb9d36275341fb8185d6e99ed
- https://github.com/denoland/deno/commit/a4003a5292bd0affefad3ecb24a8732886900f67
- https://github.com/denoland/deno/security/advisories/GHSA-2x3r-hwv5-p32x
- https://github.com/denoland/deno/security/advisories/GHSA-2x3r-hwv5-p32x
Get alerted when CVE-2025-24015 or the next vulnerability affects your stack