What’s Vulnerable › Vulnerabilities
CVE-2025-24017: YesWiki Vulnerable to Unauthenticated DOM Based XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-21 · updated 2026-06-17
- Weakness: CWE-79
Description
YesWiki is a wiki system written in PHP. Versions up to and including 4.4.5 are vulnerable to any end-user crafting a DOM based XSS on all of YesWiki's pages which is triggered when a user clicks on a malicious link. The vulnerability makes use of the search by tag feature. When a tag doesn't exist, the tag is reflected on the page and isn't properly sanitized on the server side which allows a malicious user to generate a link that will trigger an XSS on the client's side when clicked. This vulnerability allows any user to generate a malicious link that will trigger an account takeover when clicked, therefore allowing a user to steal other accounts, modify pages, comments, permissions, extract user data (emails), thus impacting the integrity, availability and confidentiality of a YesWiki instance. Version 4.5.0 contains a patch for the issue.
Affected products
- yeswiki: before 4.5.0 — fixed in 4.5.0
How to fix
Upgrade to a fixed version: yeswiki 4.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/YesWiki/yeswiki/commit/c1e28b59394957902c31c850219e4504a20db98b
- https://github.com/YesWiki/yeswiki/security/advisories/GHSA-wphc-5f2j-jhvg
Get alerted when CVE-2025-24017 or the next vulnerability affects your stack