What’s Vulnerable › Vulnerabilities
CVE-2025-24028: Cross-site Scripting (XSS) in Rich Text Editor allows arbitrary code execution in Joplin
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-02-07 · updated 2026-06-17
- Weakness: CWE-79
Description
Joplin is a free, open source note taking and to-do application, which can handle a large number of notes organised into notebooks. This vulnerability is caused by differences between how Joplin's HTML sanitizer handles comments and how the browser handles comments. This affects both the Rich Text Editor and the Markdown viewer. However, unlike the Rich Text Editor, the Markdown viewer is `cross-origin isolated`, which prevents JavaScript from directly accessing functions/variables in the toplevel Joplin `window`. This issue is not present in Joplin 3.1.24 and may have been introduced in `9b50539`. This is an XSS vulnerability that impacts users that open untrusted notes in the Rich Text Editor. This vulnerability has been addressed in version 3.2.12 and all users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- laurent22 joplin: before 3.2.12 — fixed in 3.2.12
How to fix
Upgrade to a fixed version: laurent22 joplin 3.2.12. Check the vendor advisory for mitigations.
References
- https://github.com/laurent22/joplin/commit/2a058ed8097c2502e152b26394dc1917897f5817
- https://github.com/laurent22/joplin/commit/9b505395918bc923f34fe6f3b960bb10e8cf234e
- https://github.com/laurent22/joplin/security/advisories/GHSA-5w3c-wph9-hq92
- https://joplinapp.org/help/dev/spec/note_viewer_isolation
- https://github.com/laurent22/joplin/security/advisories/GHSA-5w3c-wph9-hq92
Get alerted when CVE-2025-24028 or the next vulnerability affects your stack