What’s Vulnerable › Vulnerabilities
CVE-2025-24033: @fastify/multipart vulnerable to unlimited consumption of resources
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-23 · updated 2026-06-17
- Weakness: CWE-770
Description
@fastify/multipart is a Fastify plugin for parsing the multipart content-type. Prior to versions 8.3.1 and 9.0.3, the `saveRequestFiles` function does not delete the uploaded temporary files when user cancels the request. The issue is fixed in versions 8.3.1 and 9.0.3. As a workaround, do not use `saveRequestFiles`.
Affected products
- fastify-multipart: before 8.3.1; from 9.0.0, < 9.0.3
References
- https://github.com/fastify/fastify-multipart/issues/546
- https://github.com/fastify/fastify-multipart/pull/567
- https://github.com/fastify/fastify-multipart/security/advisories/GHSA-27c6-mcxv-x3fh
Get alerted when CVE-2025-24033 or the next vulnerability affects your stack