What’s Vulnerable › Vulnerabilities

CVE-2025-2408: Insufficient Granularity of Access Control in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions from 13.12 before 17.8.7, 17.9 before 17.9.6, and 17.10 before 17.10.4. Under certain conditions users could bypass IP access restrictions and view sensitive information.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.10.4, 17.8.7, 17.9.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-2408 or the next vulnerability affects your stack