What’s Vulnerable › Vulnerabilities
CVE-2025-24208
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-31 · updated 2026-06-17
- Weakness: CWE-79
Description
A permissions issue was addressed with additional restrictions. This issue is fixed in Safari 18.4, iOS 18.4 and iPadOS 18.4. Loading a malicious iframe may lead to a cross-site scripting attack.
Affected products
- Apple iPadOS: before 18.4 — fixed in 18.4
- Apple Iphone Os: before 18.4 — fixed in 18.4
- Apple Safari: before 18.4 — fixed in 18.4
How to fix
Upgrade to a fixed version: Apple iPadOS 18.4; Apple Iphone Os 18.4; Apple Safari 18.4. Check the vendor advisory for mitigations.
References
- https://support.apple.com/en-us/122371
- https://support.apple.com/en-us/122379
- http://seclists.org/fulldisclosure/2025/Apr/2
- http://seclists.org/fulldisclosure/2025/Apr/4
- https://lists.debian.org/debian-lts-announce/2025/06/msg00016.html
Get alerted when CVE-2025-24208 or the next vulnerability affects your stack