What’s Vulnerable › Vulnerabilities
CVE-2025-24354: imgproxy is vulnerable to SSRF against 0.0.0.0
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-27 · updated 2026-06-17
- Weakness: CWE-918
Description
imgproxy is server for resizing, processing, and converting images. Imgproxy does not block the 0.0.0.0 address, even with IMGPROXY_ALLOW_LOOPBACK_SOURCE_ADDRESSES set to false. This can expose services on the local host. This vulnerability is fixed in 3.27.2.
Affected products
- imgproxy: before 3.27.2
References
- https://github.com/imgproxy/imgproxy/commit/3d4fed6842aa8930ec224d0ad75b0079b858e081
- https://github.com/imgproxy/imgproxy/security/advisories/GHSA-j2hp-6m75-v4j4
Get alerted when CVE-2025-24354 or the next vulnerability affects your stack