What’s Vulnerable › Vulnerabilities
CVE-2025-24364: vaultwarden allows RCE in the admin panel
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-27 · updated 2026-06-17
- Weakness: CWE-74
Description
vaultwarden is an unofficial Bitwarden compatible server written in Rust, formerly known as bitwarden_rs. Attacker with authenticated access to the vaultwarden admin panel can execute arbitrary code in the system. The attacker could then change some settings to use sendmail as mail agent but adjust the settings in such a way that it would use a shell command. It then also needed to craft a special favicon image which would have the commands embedded to run during for example sending a test email. This vulnerability is fixed in 1.33.0.
Affected products
- dani-garcia vaultwarden: before 1.33.0 — fixed in 1.33.0
How to fix
Upgrade to a fixed version: dani-garcia vaultwarden 1.33.0. Check the vendor advisory for mitigations.
References
- https://github.com/dani-garcia/vaultwarden/releases/tag/1.33.0
- https://github.com/dani-garcia/vaultwarden/security/advisories/GHSA-h6cc-rc6q-23j4
Get alerted when CVE-2025-24364 or the next vulnerability affects your stack