What’s Vulnerable › Vulnerabilities
CVE-2025-24367: Cacti allows Arbitrary File Creation leading to RCE
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 54.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-27 · updated 2026-06-17
- Weakness: CWE-144
Description
Cacti is an open source performance and fault management framework. An authenticated Cacti user can abuse graph creation and graph template functionality to create arbitrary PHP scripts in the web root of the application, leading to remote code execution on the server. This vulnerability is fixed in 1.2.29.
Affected products
- cacti: before 1.2.29 — fixed in 1.2.29
How to fix
Upgrade to a fixed version: cacti 1.2.29. Check the vendor advisory for mitigations.
References
- https://github.com/Cacti/cacti/commit/c7e4ee798d263a3209ae6e7ba182c7b65284d8f0
- https://github.com/Cacti/cacti/security/advisories/GHSA-fxrq-fr7h-9rqq
- https://lists.debian.org/debian-lts-announce/2025/02/msg00010.html
- https://github.com/Cacti/cacti/security/advisories/GHSA-fxrq-fr7h-9rqq
Get alerted when CVE-2025-24367 or the next vulnerability affects your stack