What’s Vulnerable › Vulnerabilities
CVE-2025-24368: Cacti has a SQL Injection vulnerability when using tree rules through Automation API
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-27 · updated 2026-06-17
- Weakness: CWE-89
Description
Cacti is an open source performance and fault management framework. Some of the data stored in automation_tree_rules.php is not thoroughly checked and is used to concatenate the SQL statement in build_rule_item_filter() function from lib/api_automation.php, resulting in SQL injection. This vulnerability is fixed in 1.2.29.
Affected products
- cacti: before 1.2.29 — fixed in 1.2.29
How to fix
Upgrade to a fixed version: cacti 1.2.29. Check the vendor advisory for mitigations.
References
- https://github.com/Cacti/cacti/commit/c7e4ee798d263a3209ae6e7ba182c7b65284d8f0
- https://github.com/Cacti/cacti/security/advisories/GHSA-f9c7-7rc3-574c
- https://lists.debian.org/debian-lts-announce/2025/02/msg00010.html
- https://github.com/Cacti/cacti/security/advisories/GHSA-f9c7-7rc3-574c
Get alerted when CVE-2025-24368 or the next vulnerability affects your stack