What’s Vulnerable › Vulnerabilities
CVE-2025-24406: Adobe Commerce | Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') (CWE-22)
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-11 · updated 2026-06-17
- Weakness: CWE-22
Description
Adobe Commerce versions 2.4.8-beta1, 2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11 and earlier are affected by an Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability that could lead to a security feature bypass. An unauthenticated attacker could exploit this vulnerability to modify files that are stored outside the restricted directory. Exploitation of this issue does not require user interaction.
Affected products
- Adobe Commerce: before 2.4.4; 2.4.4, 2.4.4-p1, 2.4.4-p10, 2.4.4-p11, 2.4.4-p2, 2.4.4-p3 (+31) — fixed in 2.4.4
- Adobe Commerce: before 1.3.3; 1.3.3, 1.3.3-p10, 1.3.3-p11, 1.3.4, 1.3.4-p10, 1.3.4-p9 (+8) — fixed in 1.3.3
- Adobe Magento: before 2.4.4; 2.4.4, 2.4.4-p1, 2.4.4-p10, 2.4.4-p11, 2.4.4-p2, 2.4.4-p3 (+31) — fixed in 2.4.4
- Adobe Commerce: through 2.4.8-beta1
How to fix
Upgrade to a fixed version: Adobe Commerce 2.4.4; Adobe Commerce 1.3.3; Adobe Magento 2.4.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-24406 or the next vulnerability affects your stack