What’s Vulnerable › Vulnerabilities
CVE-2025-24422: Adobe Commerce | Improper Access Control (CWE-284)
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-11 · updated 2026-06-17
- Weakness: CWE-284
Description
Adobe Commerce versions 2.4.8-beta1, 2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11 and earlier are affected by an Improper Access Control vulnerability that could result in a Security feature bypass. A low-privileged attacker could leverage this vulnerability to bypass security measures and gain unauthorized read access. Exploitation of this issue does not require user interaction.
Affected products
- Adobe Commerce: before 1.3.3; 1.3.3, 1.3.3-p10, 1.3.3-p11, 1.3.4, 1.3.4-p10, 1.3.4-p9 (+8) — fixed in 1.3.3
- Adobe Commerce: through 2.4.8-beta1
How to fix
Upgrade to a fixed version: Adobe Commerce 1.3.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-24422 or the next vulnerability affects your stack