What’s Vulnerable › Vulnerabilities
CVE-2025-2443: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-20 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue has been discovered in GitLab EE that allows for cross-site-scripting attack and content security policy bypass in a user's browser under specific conditions, affecting all versions from 16.6 before 17.9.7, 17.10 before 17.10.5, and 17.11 before 17.11.1.
Affected products
- GitLab: from 16.6.0 before 17.9.7; from 17.10.0 before 17.10.5; 17.11.0 — fixed in 17.10.5, 17.9.7
How to fix
Upgrade to a fixed version: GitLab 17.10.5, 17.9.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-2443 or the next vulnerability affects your stack