What’s Vulnerable › Vulnerabilities
CVE-2025-24448: Illustrator | Out-of-bounds Read (CWE-125)
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-11 · updated 2026-06-17
- Weakness: CWE-125
Description
Illustrator versions 29.2.1, 28.7.4 and earlier are affected by an out-of-bounds read vulnerability that could lead to disclosure of sensitive memory. An attacker could leverage this vulnerability to bypass mitigations such as ASLR. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Illustrator: from 28.0 before 28.7.5; from 29.0 before 29.3 — fixed in 28.7.5, 29.3
How to fix
Upgrade to a fixed version: Adobe Illustrator 28.7.5, 29.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-24448 or the next vulnerability affects your stack