What’s Vulnerable › Vulnerabilities

CVE-2025-24477

Description

A heap-based buffer overflow vulnerability in Fortinet FortiOS 7.6.0 through 7.6.2, FortiOS 7.4.0 through 7.4.7, FortiOS 7.2.4 through 7.2.12 allows an attacker to escalate its privileges via a specially crafted CLI command

Affected products

How to fix

Upgrade to a fixed version: Fortinet FortiOS (FortiGate) 7.2.12, 7.4.8, 7.6.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-24477 or the next vulnerability affects your stack