What’s Vulnerable › Vulnerabilities
CVE-2025-24528
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-16 · updated 2026-06-17
- Weakness: CWE-190
Description
In MIT Kerberos 5 (aka krb5) before 1.22 (with incremental propagation), there is an integer overflow for a large update size to resize() in kdb_log.c. An authenticated attacker can cause an out-of-bounds write and kadmind daemon crash.
Affected products
- MIT Kerberos 5: from 1.7 before 1.22 — fixed in 1.22
How to fix
Upgrade to a fixed version: MIT Kerberos 5 1.22. Check the vendor advisory for mitigations.
References
- https://github.com/krb5/krb5/commit/78ceba024b64d49612375be4a12d1c066b0bfbd0
- https://github.com/krb5/krb5/compare/krb5-1.21.3-final...krb5-1.22-final
- https://lists.debian.org/debian-lts-announce/2025/02/msg00029.html
Get alerted when CVE-2025-24528 or the next vulnerability affects your stack