What’s Vulnerable › Vulnerabilities
CVE-2025-24644: WordPress WooCommerce PDF Invoices plugin <= 4.7.1 - Stored Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-24 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WebToffee WooCommerce PDF Invoices, Packing Slips, Delivery Notes and Shipping Labels print-invoices-packing-slip-labels-for-woocommerce allows Stored XSS.This issue affects WooCommerce PDF Invoices, Packing Slips, Delivery Notes and Shipping Labels: from n/a through <= 4.7.1.
Affected products
- WebToffee WooCommerce PDF Invoices, Packing Slips, Delivery Notes & Shipping Labels: before 4.7.2 — fixed in 4.7.2
How to fix
Upgrade to a fixed version: WebToffee WooCommerce PDF Invoices, Packing Slips, Delivery Notes & Shipping Labels 4.7.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-24644 or the next vulnerability affects your stack