What’s Vulnerable › Vulnerabilities
CVE-2025-24686: WordPress RegistrationMagic Plugin <= 6.0.3.3 - Reflected Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-31 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Metagauss RegistrationMagic custom-registration-form-builder-with-submission-manager allows Reflected XSS.This issue affects RegistrationMagic: from n/a through <= 6.0.3.3.
Affected products
- Metagauss RegistrationMagic: before 6.0.3.4 — fixed in 6.0.3.4
How to fix
Upgrade to a fixed version: Metagauss RegistrationMagic 6.0.3.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-24686 or the next vulnerability affects your stack