What’s Vulnerable › Vulnerabilities

CVE-2025-2469: Debug Messages Revealing Unnecessary Information in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions from 17.9 before 17.9.6, and 17.10 before 17.10.4. The runtime profiling data of a specific service was accessible to unauthenticated users.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.10.4, 17.9.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-2469 or the next vulnerability affects your stack