What’s Vulnerable › Vulnerabilities
CVE-2025-24731: WordPress IP2Location Country Blocker plugin <= 2.38.3 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-24 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in IP2Location Download IP2Location Country Blocker ip2location-country-blocker allows Stored XSS.This issue affects Download IP2Location Country Blocker: from n/a through <= 2.38.3.
Affected products
- IP2Location Country Blocker: before 2.38.4 — fixed in 2.38.4
How to fix
Upgrade to a fixed version: IP2Location Country Blocker 2.38.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-24731 or the next vulnerability affects your stack