What’s Vulnerable › Vulnerabilities
CVE-2025-24732: WordPress BookingPress Plugin <= 1.1.25 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-24 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in reputeinfosystems BookingPress bookingpress-appointment-booking allows DOM-Based XSS.This issue affects BookingPress: from n/a through <= 1.1.25.
Affected products
- reputeinfosystems Appointment Booking Calendar Plugin and Scheduling Plugin – BookingPress: before 1.1.26 — fixed in 1.1.26
How to fix
Upgrade to a fixed version: reputeinfosystems Appointment Booking Calendar Plugin and Scheduling Plugin – BookingPress 1.1.26. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-24732 or the next vulnerability affects your stack