What’s Vulnerable › Vulnerabilities

CVE-2025-2475: Unauthorized Bot Login Using Credentials

Description

Mattermost versions 10.5.x <= 10.5.1, 10.4.x <= 10.4.3, 9.11.x <= 9.11.9 fail to invalidate the cache when a user account is converted to a bot which allows an attacker to login to the bot exactly one time via normal credentials.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.4.4, 10.5.2, 9.11.10. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-2475 or the next vulnerability affects your stack