What’s Vulnerable › Vulnerabilities
CVE-2025-24752: WordPress Essential Addons for Elementor plugin <= 6.0.14 - Reflected Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-17 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPDeveloper Essential Addons for Elementor essential-addons-for-elementor-lite allows Reflected XSS.This issue affects Essential Addons for Elementor: from n/a through <= 6.0.14.
Affected products
- wpdevteam Essential Addons for Elementor – Popular Elementor Templates & Widgets: before 6.0.15 — fixed in 6.0.15
How to fix
Upgrade to a fixed version: wpdevteam Essential Addons for Elementor – Popular Elementor Templates & Widgets 6.0.15. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-24752 or the next vulnerability affects your stack