What’s Vulnerable › Vulnerabilities
CVE-2025-24790: Snowflake JDBC uses insecure temporary credential cache file permissions
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-29 · updated 2026-06-17
- Weakness: CWE-276
Description
Snowflake JDBC provides a JDBC type 4 driver that supports core functionality, allowing Java program to connect to Snowflake. Snowflake discovered and remediated a vulnerability in the Snowflake JDBC Driver. On Linux systems, when temporary credential caching is enabled, the Snowflake JDBC Driver will cache temporary credentials locally in a world-readable file. This vulnerability affects versions 3.6.8 through 3.21.0. Snowflake fixed the issue in version 3.22.0.
Affected products
- snowflakedb snowflake-jdbc: from 3.6.8 before 3.22.0 — fixed in 3.22.0
How to fix
Upgrade to a fixed version: snowflakedb snowflake-jdbc 3.22.0. Check the vendor advisory for mitigations.
References
- https://github.com/snowflakedb/snowflake-jdbc/commit/9e1a5acf12406b16c4780ca013f4c4db48b74b59
- https://github.com/snowflakedb/snowflake-jdbc/security/advisories/GHSA-33g6-495w-v8j2
Get alerted when CVE-2025-24790 or the next vulnerability affects your stack