What’s Vulnerable › Vulnerabilities
CVE-2025-24792: Snowflake PHP PDO Driver has a Signed-to-Unsigned Conversion Error
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-29 · updated 2026-06-17
- Weakness: CWE-195
Description
Snowflake PHP PDO Driver is a driver that uses the PHP Data Objects (PDO) extension to connect to the Snowflake database. Snowflake discovered and remediated a vulnerability in the Snowflake PHP PDO Driver where executing unsupported queries like PUT or GET on stages causes a signed-to-unsigned conversion error that crashes the application using the Driver. This vulnerability affects versions 0.2.0 through 3.0.3. Snowflake fixed the issue in version 3.1.0.
Affected products
- snowflakedb pdo_snowflake: from 0.2.0, < 3.1.0
References
Get alerted when CVE-2025-24792 or the next vulnerability affects your stack