What’s Vulnerable › Vulnerabilities
CVE-2025-24793: Snowflake Connector for Python has an SQL Injection in write_pandas
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-29 · updated 2026-06-17
- Weakness: CWE-89
Description
The Snowflake Connector for Python provides an interface for developing Python applications that can connect to Snowflake and perform all standard operations. Snowflake discovered and remediated a vulnerability in the Snowflake Connector for Python. A function from the snowflake.connector.pandas_tools module is vulnerable to SQL injection. This vulnerability affects versions 2.2.5 through 3.13.0. Snowflake fixed the issue in version 3.13.1.
Affected products
- snowflakedb snowflake-connector-python: from 2.2.5 before 3.13.1 — fixed in 3.13.1
How to fix
Upgrade to a fixed version: snowflakedb snowflake-connector-python 3.13.1. Check the vendor advisory for mitigations.
References
- https://github.com/snowflakedb/snowflake-connector-python/commit/f3f9b666518d29c31a49384bbaa9a65889e72056
- https://github.com/snowflakedb/snowflake-connector-python/security/advisories/GHSA-2vpq-fh52-j3wv
Get alerted when CVE-2025-24793 or the next vulnerability affects your stack