What’s Vulnerable › Vulnerabilities
CVE-2025-24794: The Snowflake Connector for Python uses insecure deserialization of the OCSP response cache
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-29 · updated 2026-06-17
- Weakness: CWE-502
Description
The Snowflake Connector for Python provides an interface for developing Python applications that can connect to Snowflake and perform all standard operations. Snowflake discovered and remediated a vulnerability in the Snowflake Connector for Python. The OCSP response cache uses pickle as the serialization format, potentially leading to local privilege escalation. This vulnerability affects versions 2.7.12 through 3.13.0. Snowflake fixed the issue in version 3.13.1.
Affected products
- snowflakedb snowflake-connector-python: from 2.7.12 before 3.13.1 — fixed in 3.13.1
How to fix
Upgrade to a fixed version: snowflakedb snowflake-connector-python 3.13.1. Check the vendor advisory for mitigations.
References
- https://github.com/snowflakedb/snowflake-connector-python/commit/3769b43822357c3874c40f5e74068458c2dc79af
- https://github.com/snowflakedb/snowflake-connector-python/security/advisories/GHSA-m4f6-vcj4-w5mx
Get alerted when CVE-2025-24794 or the next vulnerability affects your stack