What’s Vulnerable › Vulnerabilities
CVE-2025-24799: GLPI allows unauthenticated SQL injection through the inventory endpoint
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 86.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-18 · updated 2026-06-17
- Weakness: CWE-89
Description
GLPI is a free asset and IT management software package. An unauthenticated user can perform a SQL injection through the inventory endpoint. This vulnerability is fixed in 10.0.18.
Affected products
- glpi-project glpi: from 10.0.0 before 10.0.18 — fixed in 10.0.18
How to fix
Upgrade to a fixed version: glpi-project glpi 10.0.18. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-24799 or the next vulnerability affects your stack