What’s Vulnerable › Vulnerabilities

CVE-2025-24807: Fast DDS does not verify Permissions CA

Description

eprosima Fast DDS is a C++ implementation of the DDS (Data Distribution Service) standard of the OMG (Object Management Group). Prior to versions 2.6.10, 2.10.7, 2.14.5, 3.0.2, 3.1.2, and 3.2.0, per design, PermissionsCA is not full chain validated, nor is the expiration date validated. Access control plugin validates only the S/MIME signature which causes an expired PermissionsCA to be taken as valid. Even though this issue is responsible for allowing `governance/permissions` from an expired PermissionsCA and having the system crash when PermissionsCA is not self-signed and contains the full-chain, the impact is low. Versions 2.6.10, 2.10.7, 2.14.5, 3.0.2, 3.1.2, and 3.2.0 contain a fix for the issue.

Affected products

How to fix

Upgrade to a fixed version: eProsima Fast-DDS 2.10.7, 2.14.5, 2.6.10, 3.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-24807 or the next vulnerability affects your stack