What’s Vulnerable › Vulnerabilities
CVE-2025-24808: Discourse has race condition when adding users to a group DM
- Severity: low (CVSS 3.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-26 · updated 2026-06-17
- Weakness: CWE-362
Description
Discourse is an open-source discussion platform. Prior to versions `3.3.4` on the `stable` branch and `3.4.0.beta5` on the `beta` branch, someone who is about to reach the limit of users in a group DM may send requests to add new users in parallel. The requests might all go through ignoring the limit due to a race condition. The patch in versions `3.3.4` and `3.4.0.beta5` uses the `lock` step in service to wrap part of the `add_users_to_channel` service inside a distributed lock/mutex in order to avoid the race condition.
Affected products
- discourse: before 3.3.3; before 3.4.0; 3.4.0-beta1, 3.4.0-beta2, 3.4.0-beta3, 3.4.0-beta4 — fixed in 3.3.3, 3.4.0
How to fix
Upgrade to a fixed version: discourse 3.3.3, 3.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/a16b2f224860f6678f89f5ffa012f0ede17e4095
- https://github.com/discourse/discourse/security/advisories/GHSA-hfcx-qjw6-573r
Get alerted when CVE-2025-24808 or the next vulnerability affects your stack