What’s Vulnerable › Vulnerabilities
CVE-2025-24813: Apache Tomcat Path Equivalence Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2025-04-01
- EPSS: 99.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-10 · updated 2026-06-17
- Weakness: CWE-44
Description
Path Equivalence: 'file.Name' (Internal Dot) leading to Remote Code Execution and/or Information disclosure and/or malicious content added to uploaded files via write enabled Default Servlet in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.2, from 10.1.0-M1 through 10.1.34, from 9.0.0.M1 through 9.0.98. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. If all of the following were true, a malicious user was able to view security sensitive files and/or inject content into those files: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - a target URL for security sensitive uploads that was a sub-directory of a target URL for public uploads - attacker knowledge of the names of security sensitive files being uploaded - the security sensitive files also being uploaded via partial PUT If all of the following were true, a malicious user was able to perform remote code execution: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - application was using Tomcat's file based session persistence with the default storage location - application included a library that may be leveraged in a deserialization attack Users are recommended to upgrade to version 11.0.3, 10.1.35 or 9.0.99, which fixes the issue.
Summary
CVE-2025-24813 is a critical path equivalence flaw in Apache Tomcat that can enable remote code execution, information disclosure, or injection of malicious content into uploaded files. It affects Tomcat 11.0.0-M1 through 11.0.2, 10.1.0-M1 through 10.1.34, and 9.0.0.M1 through 9.0.98, plus EOL 8.5.0 through 8.5.100. Exploitation requires non-default conditions such as writes enabled for the Default Servlet, though partial PUT is on by default. The flaw is listed in CISA KEV with active exploitation and a public exploit exists, so upgrade to 11.0.3, 10.1.35, or 9.0.99 immediately and apply vendor mitigations where patching is not yet possible.
CVE-2025-24813 ثغرة حرجة في Apache Tomcat تتعلق بتكافؤ المسارات وقد تؤدي إلى تنفيذ تعليمات برمجية عن بُعد أو كشف معلومات حساسة أو حقن محتوى ضار في الملفات المرفوعة. تؤثر في الإصدارات 11.0.0-M1 حتى 11.0.2 و10.1.0-M1 حتى 10.1.34 و9.0.0.M1 حتى 9.0.98، إضافة إلى الإصدارات المنتهية الدعم 8.5.0 حتى 8.5.100. يتطلب الاستغلال شروطاً غير افتراضية مثل تفعيل الكتابة في Default Servlet، رغم أن partial PUT مفعّل افتراضياً. الثغرة مدرجة في CISA KEV مع استغلال نشط ووجود exploit عام، لذا يجب الترقية فوراً إلى 11.0.3 أو 10.1.35 أو 9.0.99 وتطبيق توصيات المورّد عند تعذّر الترقية.
Affected products
- Apache Tomcat: before 9.0.99; from 10.1.1 before 10.1.35; from 11.0.1 before 11.0.3; 10.1.0-milestone1, 10.1.0-milestone10, 10.1.0-milestone11, 10.1.0-milestone12, 10.1.0-milestone13, 10.1.0-milestone14 (+39) — fixed in 10.1.35, 11.0.3, 9.0.99
- Debian Linux: 11.0
- NetApp Bootstrap Os: all versions
How to fix
Upgrade to a fixed version: Apache Tomcat 10.1.35, 11.0.3, 9.0.99. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/j5fkjv2k477os90nczf2v9l61fb0kkgq
- http://www.openwall.com/lists/oss-security/2025/03/10/5
- https://lists.debian.org/debian-lts-announce/2025/04/msg00003.html
- https://security.netapp.com/advisory/ntap-20250321-0001/
- https://www.vicarius.io/vsociety/posts/cve-2025-24813-detect-apache-tomcat-rce
- https://www.vicarius.io/vsociety/posts/cve-2025-24813-mitigate-apache-tomcat-rce
- https://www.vicarius.io/vsociety/posts/cve-2025-24813-tomcat-detect-vulnerability
- https://www.vicarius.io/vsociety/posts/cve-2025-24813-tomcat-mitigation-vulnerability
- https://github.com/absholi7ly/POC-CVE-2025-24813/blob/main/README.md
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-24813
Get alerted when CVE-2025-24813 or the next vulnerability affects your stack