What’s Vulnerable › Vulnerabilities
CVE-2025-24814: Apache Solr: Core-creation with "trusted" configset can use arbitrary untrusted files
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-27 · updated 2026-06-17
- Weakness: CWE-250
Description
Core creation allows users to replace "trusted" configset files with arbitrary configuration Solr instances that (1) use the "FileSystemConfigSetService" component (the default in "standalone" or "user-managed" mode), and (2) are running without authentication and authorization are vulnerable to a sort of privilege escalation wherein individual "trusted" configset files can be ignored in favor of potentially-untrusted replacements available elsewhere on the filesystem. These replacement config files are treated as "trusted" and can use "<lib>" tags to add to Solr's classpath, which an attacker might use to load malicious code as a searchComponent or other plugin. This issue affects all Apache Solr versions up through Solr 9.7. Users can protect against the vulnerability by enabling authentication and authorization on their Solr clusters or switching to SolrCloud (and away from "FileSystemConfigSetService"). Users are also recommended to upgrade to Solr 9.8.0, which mitigates this issue by disabling use of "<lib>" tags by default.
Affected products
- Apache Software Foundation Apache Solr: before 9.8.0 — fixed in 9.8.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Solr 9.8.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/gl291pn8x9f9n52ys5l0pc0b6qtf0qw1
- http://www.openwall.com/lists/oss-security/2025/01/26/1
- https://security.netapp.com/advisory/ntap-20250214-0002/
Get alerted when CVE-2025-24814 or the next vulnerability affects your stack