What’s Vulnerable › Vulnerabilities

CVE-2025-24839: Unauthorized AI bot activation via Wrangler plugin

Description

Mattermost versions 10.5.x <= 10.5.1, 10.4.x <= 10.4.3, 9.11.x <= 9.11.9 fail to prevent Wrangler posts from triggering AI responses. This vulnerability allows users without access to the AI bot to activate it by attaching the activate_ai override property to a post via the Wrangler plugin, provided both the AI and Wrangler plugins are enabled.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.4.4, 10.5.2, 9.11.10. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-24839 or the next vulnerability affects your stack