What’s Vulnerable › Vulnerabilities
CVE-2025-24853: Apache JSPWiki: Cross-Site Scripting (XSS) in JSPWiki Header Link processing
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-31 · updated 2026-06-17
- Weakness: CWE-79
Description
A carefully crafted request when creating a header link using the wiki markup syntax, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Further research by the JSPWiki team showed that the markdown parser allowed this kind of attack too. Apache JSPWiki users should upgrade to 2.12.3 or later.
Affected products
- Apache Software Foundation Apache JSPWiki: before 2.12.3 — fixed in 2.12.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache JSPWiki 2.12.3. Check the vendor advisory for mitigations.
References
- https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2025-24853
- http://www.openwall.com/lists/oss-security/2025/07/30/2
Get alerted when CVE-2025-24853 or the next vulnerability affects your stack