What’s Vulnerable › Vulnerabilities
CVE-2025-24854: Apache JSPWiki: Cross-Site Scripting (XSS) in JSPWiki Image plugin
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-31 · updated 2026-06-17
- Weakness: CWE-79
Description
A carefully crafted request using the Image plugin could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.12.3 or later.
Affected products
- Apache Software Foundation Apache JSPWiki: before 2.12.3 — fixed in 2.12.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache JSPWiki 2.12.3. Check the vendor advisory for mitigations.
References
- https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2025-24854
- http://www.openwall.com/lists/oss-security/2025/07/30/3
Get alerted when CVE-2025-24854 or the next vulnerability affects your stack