What’s Vulnerable › Vulnerabilities
CVE-2025-24859: Apache Roller: Insufficient Session Expiration on Password Change
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-14 · updated 2026-06-17
- Weakness: CWE-613
Description
A session management vulnerability exists in Apache Roller before version 6.1.5 where active user sessions are not properly invalidated after password changes. When a user's password is changed, either by the user themselves or by an administrator, existing sessions remain active and usable. This allows continued access to the application through old sessions even after password changes, potentially enabling unauthorized access if credentials were compromised. This issue affects Apache Roller versions up to and including 6.1.4. The vulnerability is fixed in Apache Roller 6.1.5 by implementing centralized session management that properly invalidates all active sessions when passwords are changed or users are disabled.
Affected products
- Apache Software Foundation Apache Roller: from 1.0 before 6.1.5 — fixed in 6.1.5
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Roller 6.1.5. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/4j906k16v21kdx8hk87gl7663sw7lg7f
- https://lists.apache.org/thread/vxv52vdr8nhtjlj6v02w43fdvo0cxw23
- http://www.openwall.com/lists/oss-security/2025/04/11/1
Get alerted when CVE-2025-24859 or the next vulnerability affects your stack